解決錯誤:Error : Please Select android SDK

今天遇見一個問題,在協同開發的時候,我一個同事從Git 上Clone 我的項目的時候報錯提示:Please Select android SDK,隨後在啟動(Debug / Start)時也提示該錯誤無法啟動

原因:

app.iml裡面沒有任何描述SDK訊息的地方,且JDK編譯版本為1.6,而我的Android Studio為3.+版本,我斷定可能是impl的問題,

什麼是IMPL?:

是Android Studio的工程配置文件,主要記錄當前project的一些配置訊息,有點兒像.project文件

解決方案:

1. 在File -> Project Structure 下面, 將JDK Location 指向本機安裝的JDK文件夾(C:\Program Files\Java\jdk1.8.0_152),然後點擊 OK.

2. 然後在File -> Invalidate Caches / Restart -> 在彈窗上選擇第一項【Invalidate And Restart】

3.重新打開Android Studio後,你會發現,工程的app.iml被刷新了,問題解決了。